Back to overview
Degraded
Notes processing time is slower than usual
Apr 29, 2026 at 4:42pm UTC
Affected services
Web Application at https://app.upheal.io
Integration API
Resolved
Apr 29, 2026 at 6:11pm UTC
The processing is back to normal.
Affected services
Updated
Apr 29, 2026 at 5:44pm UTC
The processing times are back to normal. We are monitoring the situation.
Affected services
Updated
Apr 29, 2026 at 5:13pm UTC
We identified an issue with our AI vendor and are working on resolution.
Affected services
Created
Apr 29, 2026 at 4:42pm UTC
Our engineering team is addressing the issue
Affected services