Back to overview
Degraded
We detected slowness in the web and API responses
Mar 12 at 04:13pm EDT
Affected services
Web Application at https://app.upheal.io
Integration API
Resolved
Mar 12 at 04:20pm EDT
The situation is back to normal
Affected services
Updated
Mar 12 at 04:19pm EDT
The situation is stabilizing and reponse times are getting back to normal
Affected services
Created
Mar 12 at 04:13pm EDT
Our engineering team is working on remediations
Affected services