Back to overview
Degraded
Our services are recovering
Oct 20 at 04:39pm EDT
Affected services
Web Application at https://app.upheal.io
API
Resolved
Oct 20 at 07:13pm EDT
Our services are fully functional
Affected services
Created
Oct 20 at 04:39pm EDT
We’re making steady progress in recovering our core services. Session processing may still experience intermittent delays as we continue working toward full restoration.
Affected services