Back to overview
Degraded
Degraded experience due to AWS outage
Oct 20 at 11:56am EDT
Affected services
Web Application at https://app.upheal.io
API
Integration API
Resolved
Oct 20 at 07:13pm EDT
Our services are fully fuctional
Affected services
Created
Oct 20 at 11:56am EDT
We are facing performance issues due to continued issues with our cloud provider, and are working on resolving them.
Affected services