Back to overview
Degraded

Calendar connection issues

Jul 24 at 08:24am EDT
Affected services
Web Application at https://app.upheal.io

Resolved
Jul 25 at 02:00pm EDT

The issue with connecting calendars was resolved.

Created
Jul 24 at 08:24am EDT

We are currently experiencing an issue with our calendar integration.