Back to overview
Downtime

App unavailable

Sep 11 at 09:06am EDT
Affected services
Web Application at https://app.upheal.io

Resolved
Sep 11 at 09:17am EDT

The fix was deployed

Updated
Sep 11 at 09:09am EDT

We are deploying a fix now

Updated
Sep 11 at 09:06am EDT

We are experiencing a problem with sign into the application

Created
Sep 11 at 09:06am EDT

W have identified the issue and working on the fix